Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
01-12-2016, 11:48 AM, (This post was last modified: 09-02-2018, 04:26 PM by Victor. Edit Reason: update changelog )
#1
2.7
Changelog:

Features:
  • Toggle zoom/iron sights/ADS, crouch, and sprint/walk (instead of holding) (#196)
  • Classic mutator enhancements
    • Perks preselected (light/streak)
    • Long flag indicator interval (10 s)
    • Shorter spawn protection time (1000 ms)
    • Nerf RPG-7 range slightly
    • No throwing knife bleeding
    • Nerf killstreaks (less airstrike damage, radar is shorter, nuke takes 60 seconds to activate)
  • /crosshairmode to use or force AC-style crosshairs (default is both)
  • Informative loading screen text (131/#149)
  • HUD speed meter
  • New collect and harvester gamemodes as 'confirm overload'
  • Teleport killers to victims in 'void' mutator (#203), also swap teams with 'convert-void' mutators
Fixes:
  • Fix server registration bug (#205) inherited from AC 1.0.4
  • Fix LAG bug (root cause is how clients handle falling damage)
  • Fix master-server update lockout bug (when resolving fails)
  • Fix vote evaluation on disconnect
  • Ignore map checks (fix old maps like acr_recreation)
  • Fix acr_recreation (pass more AC map checks), add ac_desert and ac_douze with flags
  • Prevent forcing AFK spectators to SPECT
  • Fix assisted suicide scoring (http://forum.acr.victorz.ca/thread-1492-...ml#pid8343)
  • Disable bots when all humans are in SPECT
  • Show ping of old/new servers in the server list
  • Show colored server name on scoreboard

Best regards,
Victor
//victorz.ca
Code:
Your antithesis compares favorably with any high magnitude of pwnage. (-you > |p|, you < -|p|)
My antithesis compares favorably with _that of_ any high magnitude of pwnage. (|-me| > |-p|, |me| > |p|)
Post Reply Quote this message in a reply
01-23-2016, 04:46 PM,
#2
RE: [Future] 2.6.4 (maybe 2.7)
Fix the pCube maps glitch also will be a good idea

The maps made with this Cube mod have CUBE as head and 6 as version number.

These maps are mistaken by AC/ACR for early AC maps, that also have 6 as version number.

They have the eighteen entity types, the seventeen ones of the latest releases of Cube and the CTF flags,

This cause several problems :
- most entities aren't correctly converted
- in ACR 2.6.3, when an entity of the types 16 to 18 (trigger, jumppad and ctf-flag in pCube) become the closest entity in edit mode, or if i switch to edit mode in a location from where a such entity is the closest one, the game crash (I didn't tried with the versions 2.6.1 and 2.6.2 but I think it will work the same way if I try to do it)

Post Reply Quote this message in a reply
01-24-2016, 02:10 PM, (This post was last modified: 06-04-2017, 04:58 PM by Victor. Edit Reason: Shorten commit hash )
#3
RE: [Future] 2.6.4 (maybe 2.7)
@asmanel, does it have something to do with a change after AC 1.0? Is it fixed by assaultcube/[email protected]?

Best regards,
Victor
//victorz.ca
Code:
Your antithesis compares favorably with any high magnitude of pwnage. (-you > |p|, you < -|p|)
My antithesis compares favorably with _that of_ any high magnitude of pwnage. (|-me| > |-p|, |me| > |p|)
Post Reply Quote this message in a reply
01-24-2016, 07:40 PM, (This post was last modified: 01-26-2016, 08:06 AM by asmanel.)
#4
RE: [Future] 2.6.4 (maybe 2.7)
I don't know the code of old AC versions.

I also tried to do it with the versions 2.5.8 and 2.5.9 of ACR. The entities was misconverted the same way but no one cause crash.

About this commit, it can't fix this glitch because it continue implying any map with 6 as version number is an AC map.

P.S. : I had a doubt about old AC maps. I downloaded one and checked its head and its version number. As what I though, the version number is 6 and the head is ACMP, not CUBE.

Post Reply Quote this message in a reply
04-20-2018, 05:01 PM, (This post was last modified: 04-20-2018, 05:01 PM by Victor.)
#5
RE: [Future] 2.6.4 (maybe 2.7)
Because 2.6.4 has some important bugfixes, this release will be important.

I will attempt to release it by September 2018, but there is no guarantee.

Best regards,
Victor
//victorz.ca
Code:
Your antithesis compares favorably with any high magnitude of pwnage. (-you > |p|, you < -|p|)
My antithesis compares favorably with _that of_ any high magnitude of pwnage. (|-me| > |-p|, |me| > |p|)
Post Reply Quote this message in a reply
09-03-2018, 04:44 PM,
#6
RE: 2.7
Enjoy ACR 2.7, which has been released!

Best regards,
Victor
//victorz.ca
Code:
Your antithesis compares favorably with any high magnitude of pwnage. (-you > |p|, you < -|p|)
My antithesis compares favorably with _that of_ any high magnitude of pwnage. (|-me| > |-p|, |me| > |p|)
Post Reply Quote this message in a reply


Forum Jump: