Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Getting errors- Linux (Debian)
06-24-2015, 05:37 PM,
#1
Getting errors- Linux (Debian)
I have an Assault Cube Server and I now decided to give a try on Assault Cube Reloaded. I have edited the config files and uploaded ACR Linux files on my VPS. Now the problem that I am facing is below;
Code:
[email protected]:~# cd /home
[email protected]@echodev:/home# cd acr
[email protected]@echodev:/home/acr# ./server.sh
.//bin_unix/linux_server: error while loading shared libraries: libenet.so.2: cannot open shared object file: No such file or directory

My mind tells that this error is caused because I am also hosting an Assault Cube Server on the same VPS.
Help me on this and I really want to create ACR server, the server will have players as my friends want to play this game and have downloaded already but there is no listing on servers on MASTER SERVER. I guess its because there is no server hosted for this game atm.
Reply
06-24-2015, 08:43 PM, (This post was last modified: 06-24-2015, 08:46 PM by Victor.)
#2
RE: Getting errors- Linux (Debian)
It can probably be fixed with
Code:
apt-get install libenet

EDIT: If that fails, try apt-cache search libenet and installing libenet2a or something like that.

Best regards,
Victor
//victorz.ca
Code:
Your antithesis compares favorably with any high magnitude of pwnage. (-you > |p|, you < -|p|)
My antithesis compares favorably with _that of_ any high magnitude of pwnage. (|-me| > |-p|, |me| > |p|)
Reply
06-24-2015, 09:38 PM, (This post was last modified: 06-24-2015, 10:00 PM by neal777.)
#3
RE: Getting errors- Linux (Debian)
I have tried few things and here are the results;
Code:
[email protected]@echodev:~# apt-get install libenet
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libenet
NOTE: I have not added SUDO because I am using the VPS as a ROOT user.
Code:
[email protected]@echodev:~# apt-get install libenet2a
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libenet2a


Code:
[email protected]@echodev:~# apt-cache search libenet
libenet-dev - thin network communication layer on top of UDP - headers
libenet-doc - thin network communication layer on top of UDP - documentation
libenet7 - thin network communication layer on top of UDP
libenet7-dbg - thin network communication layer on top of UDP - debug symbols
[email protected]@echodev:~# apt-get install libenet2a
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libenet2a
None of the commands that you suggested are working in this case ;/
Maybe I had edited the config files inappropriately? Do I have to remove default from file like default.servercmdline.txt? I haven't removed default.
Will it work if I create Assault Cube Reloaded server by using Assault Cube files and changing the master server to Assault Cube Reloaded maser server? Can I have IP and Domain of master server?
Can you also tell me in which file the master server Domain/IP is saved? -I have seen the file before but I forgot Tongue Tongue Tongue

Thank you for your help!
Best Regards,
Neal777
Reply
06-26-2015, 06:05 AM, (This post was last modified: 06-26-2015, 06:40 AM by neal777.)
#4
RE: Getting errors- Linux (Debian)
Hi again,
Today I will provide here some links to prove this problem is not faced by me only. There are several other users as well. I hope ACR developer fix this problem ASAP or provides solution if there is.
http://www.forum-raspberrypi.de/Thread-p...spberry-pi
http://www.ubuntucafe.in/2013/10/solved-...hared.html- The give solution which do not work for me.
http://forum.ubuntuusers.de/topic/assaul...tallieren/
Reply
06-26-2015, 11:12 AM, (This post was last modified: 06-26-2015, 11:15 AM by Victor.)
#5
RE: Getting errors- Linux (Debian)
Try installing libenet7 and if that fails, libenet-dev.

If it still doesn't work, you might have to install the rest of the dev packages and compile a server.

Actually, the install command from the Travis script in our repo is more suitable:
Code:
apt-get install -qq build-essential libsdl1.2debian libsdl-image1.2 libopenal1 libsdl1.2-dev libsdl-image1.2-dev libopenal-dev libvorbis-dev libcurl3-dev libenet-dev

Best regards,
Victor
//victorz.ca
Code:
Your antithesis compares favorably with any high magnitude of pwnage. (-you > |p|, you < -|p|)
My antithesis compares favorably with _that of_ any high magnitude of pwnage. (|-me| > |-p|, |me| > |p|)
Reply
08-14-2015, 02:28 AM, (This post was last modified: 08-14-2015, 02:31 AM by ztealmax.)
#6
RE: Getting errors- Linux (Debian)
Dont work for me either tried it on both Ubuntu and Debian
however works great on Beta 1 but cant play online since it says update client..

Something you changed in the code on Beta 2?

Code:
apt-get install -qq build-essential libsdl1.2debian libsdl-image1.2 libopenal1 libsdl1.2-dev libsdl-image1.2-dev libopenal-dev libvorbis-dev libcurl3-dev libenet-dev
Installed still no go.

Quote:bin_unix/linux_64_client: error while loading shared libraries: libenet.so.2: cannot open shared object file: No such file or directory

Tried it on both 64-bit and 32-bit Debian 8.1

I wondering if libenet.so.2 is pointing to the wrong path in the beta 2 code since beta 1 works?
Reply
08-14-2015, 08:46 AM,
#7
RE: Getting errors- Linux (Debian)
In the chat box, @ztealmax installed "libenet2a_1.3.11+ds-1_amd64.deb" and fixed it.

We should link libenet statically (Issue #188).

Best regards,
Victor
//victorz.ca
Code:
Your antithesis compares favorably with any high magnitude of pwnage. (-you > |p|, you < -|p|)
My antithesis compares favorably with _that of_ any high magnitude of pwnage. (|-me| > |-p|, |me| > |p|)
Reply
08-14-2015, 12:25 PM,
#8
RE: Getting errors- Linux (Debian)
Thank you Victor!

/Martin
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)