Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Server hosting problems
04-05-2015, 09:49 PM,
#1
Sad  Server hosting problems
I am trying to host a small 24/7 server for ACR, but I'm also having problems with that.  The client program runs fine, on any of the recent versions.  However, when I try running a server, I get a lot of problems.
When I run the new year release server, I get an update warning. That sort of makes sense, because there are two newer versions, but not very much, since those two are both beta versions.
When I try running Beta 1 and Beta 2 servers, I get a windows error message that it is not a valid Win/32 program.
Does anyone have any suggestions?  I not actually using a server OS, but Windows XP Media Center.
Thanks!
Reply
04-06-2015, 10:22 AM, (This post was last modified: 04-06-2015, 10:23 AM by Victor.)
#2
RE: Server hosting problems
I just realized that I compiled the client with Windows XP support but forgot to compile the server with Windows XP support.

For the next version, I should just compile on Visual Studio 2008 to get Windows 2000 support back and prevent this issue.

Anyway, I've recompiled an ACR 2.6.2 server binary with XP support: https://github.com/acreloaded/acr/releas...er_bin.zip

Best regards,
Victor
//victorz.ca
Code:
Your antithesis compares favorably with any high magnitude of pwnage. (-you > |p|, you < -|p|)
My antithesis compares favorably with _that of_ any high magnitude of pwnage. (|-me| > |-p|, |me| > |p|)
Reply
04-07-2015, 10:47 AM, (This post was last modified: 04-07-2015, 11:11 AM by IBiteBack.)
#3
RE: Server hosting problems
Ah, that would explain the problem. Thanks!
I will try it again when I get the chance.

Alright, with that version of the server, I got it working.
One more question, is there a way to disable the automatic generation of bots? While that is a nice feature, it makes 1v1 match servers rather pointless.
Reply
04-07-2015, 11:42 AM,
#4
RE: Server hosting problems
I don't know how it will work if you do it but did you try to use the bots menu ?

Reply
04-07-2015, 01:40 PM,
#5
RE: Server hosting problems
Thanks for the suggestion, asmanel, but I think the bot menu can only be found while editing a map. it is used for configuring it for bots. I don't think I can use it to change the appearance of bots on my server in general, though.
Reply
04-08-2015, 10:58 AM,
#6
RE: Server hosting problems
Actually, the bots menu is and remain at the same location anywhen.

Theorically, it will be enough, unless you want to prevent normal players from add bots if they want it.

Reply
04-08-2015, 08:16 PM,
#7
RE: Server hosting problems
Oh, I guess I don't know what you're talking about. I'm thinking of the bots menu which is available in edit mode. How can I get to the one you are talking about?
------------------
Also, I now I have a new problem. After about three people connect to my server (counting from when I started it) The server crashes with the error message "startgame abused"
Does anyone know what I can do about this?

Thanks!
Reply
04-09-2015, 06:40 PM,
#8
RE: Server hosting problems
From the code, if "startgame() abused" causes a crash, it is probably near the end of a round or when a new map is loaded. It seems unlikely to be due to more connecting players. However, I need more information to fix this bug.

Best regards,
Victor
//victorz.ca
Code:
Your antithesis compares favorably with any high magnitude of pwnage. (-you > |p|, you < -|p|)
My antithesis compares favorably with _that of_ any high magnitude of pwnage. (|-me| > |-p|, |me| > |p|)
Reply
04-10-2015, 11:41 AM,
#9
RE: Server hosting problems
@IBiteBack visibly, bot aren't related at all to the edit mode. I think edit maps is the only thing you do offline with ACR.

There only is one menu to manage bot in the whole game.

When you are connected, the menu you open when you press the escape key is the multiplayer menu. By the entries it contain, there is "Main menu...", that open the main menu (the true main menu), the menu you open at pressing the escape key when you aren't connected.

From the main menu, select "Singleplayer" then "Bot Control" to open the bots menu. If you fear a disconnection (theorycally, it won't happen), there an other way to open it : type /showmenu "Bot control" in the console.

Both when you are connected and when you aren't connected, the fact you are or not in edit mode doesn't affect the reachability of the menus, except the editing menu, that can be opened with a right clic only if you are in edit mode (this menu, however isn't part of any way ro reach the bots menu).

Reply
04-13-2015, 04:30 PM, (This post was last modified: 04-13-2015, 04:33 PM by IBiteBack. Edit Reason: Added note about server problem )
#10
RE: Server hosting problems
Alright, thank you, asmanel. Sorry to require so much detail, but that is helpful. Do I assume correctly then that only a client can change the appearance of bots, then, and this cannot be set server-side?
-------
Victor, I've uploaded a few logs with the error here: https://dl.dropboxusercontent.com/u/7297...abused.zip

Looking through them, I realized you might be right. None of them show an incoming connection before the crash. Once, I say it on the console output, but I can't seem to find that in any of my logs. Perhaps it crashed before the string was sent to the log, or perhaps I've lost it somehow.

I don't know if it will help--let me know if there's anything else you want/need
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)